锐捷交换机基本命令

最近项目上用到了锐捷系列的交换机,所以整理了一些基本命令,以供后续使用。

console配置信息

交换机查看信息命令
// LESS CODE

0
#show running-config //查看当前生效的配置信息
1
  #show interface fastethernet 0/3 //查看F0/3端口信息
2
  #show interface serial 1/2 //查看S1/2端口信息
3
  #show interface //查看所有端口信息
4
  #show ip interface brief //以简洁方式汇总查看所有端口信息
5
  #show ip interface //查看所有端口信息
6
  #show version //查看版本信息
7
  #show mac-address-table //查看交换机当前MAC地址表信息
8
  #show running-config //查看当前生效的配置信息
9
  #show vlan //查看所有VLAN信息
10
  #show vlan id 10 //查看某一VLAN (如VLAN10)的信息
11
  #show interface fastethernet 0/1 //查看某一端口模式(如F 0/1)
12
  #show aggregateport 1 summary //查看聚合端口AG1的信息
13
  #show spanning-tree //查看生成树配置信息
14
  #show spanning-tree interface fastethernet 0/1 //查看该端口的生成树状态
15
  #show port-security //查看交换机的端口安全配置信息
16
  #show port-security address //查看地址安全绑定配置信息
17
  #show ip access-lists listname //查看名为listname的列表的配置信息

一、交换机配置模式介绍

交换机配置模式主要有:

用户模式:此模式只可以简单的查看一些交换机的配置和一些简单的修改。

// LESS CODE

0
Switch>

特权模式:此模式可以查看一些交换机的配置,后面讲述的很多show命令便是在此模式下进行的,还可以对一些简单的设置配置,例如时间。

// LESS CODE

0
Switch>enable //在用户模式下输入enable将进入配置模式
1
Switch#

全局配置模式:此模式下可以进行对交换机的配置,例如:命名、配置密码、设路由等。

// LESS CODE

0
Switch#configure erminal //特权模式下可以通过config terminal 命令进入配置模式
1
Switch(config)#

端口配置模式:此模式下对端口进行配置,如配置端口ip等。

// LESS CODE

0
Switch(config)#interface gigabitEthernet 1/1 //配置模式下输入interface gigabitEthernet 1/1进入到端口g 1/1接口模式

二、交换机基本配置

交换机命名:在项目实施的时候,建议为处于不同位置的交换机命名,便于记忆,可提高后期管理效率。

// LESS CODE

0
switch(config)#hostname ruijie //ruijie为该交换机的名字

交换机配置管理密码:配置密码可以提高交换机的安全性,另外,telnet登录交换机的时候,必须要求有telnet管理密码。

// LESS CODE

0
switch (config)#enable secret level 1 0 ruijie //配置telnet管理密码为ruijie,其中1表示为telnet密码,0表示密码不加密
1
switch (config)#enable secret level 15 0 ruijie //配置特权模式下的管理密码ruijie,其中15表示为特权密码,0表示密码不加密

Level 1为普通用户级别,可选为1~15,15为最高权限级别;0表示密码不加密

交换机配置管理IP

// LESS CODE

0
switch (config)#interface vlan 1 //假设管理VLANVLAN1
1
switch (config-if)#ip address 192.168.1.1 255.255.255.0 //给管理VLAN配置管理IP地址, 二层交换机只能配置一个IP,此IP是作为管理IP使用,例如,使用Telnet的方式登录的IP地址 
2
switch (config-if)#no shutdown //激活管理IP,养成习惯,无论配置什么设备,都使用一下这个命令

交换机配置网关:

// LESS CODE

0
switch(config)#ip default-gateway 192.168.1.254 //假设网关地址为192.168.1.254,此命令用于二层设备

交换机telnet管理功能:

// LESS CODE

0
switch(config)#enable services telnet-server //开启交换机telnet管理功能
1
switch(config)#line vty 0 4
2
switch(config-line)#password ruijie //密码为ruijie
3
switch(config-line)#end

Services 可选以下:web-server(WEB管理)、telnet-server(远程登陆)等

通过以上几个命令的配置,设备便可以实现远程管理,在项目实施时(尤其是设备位置比较分散)特别能提高效率。

接口介质类型配置

锐捷为了降低SME客户的总体拥有成本,推出灵活选择的端口形式:电口和光口复用接口,方便用户根据网络环境选择对应的介质类型。但光口和电口同时只能用其一,如使用了光口1F,则电口1不能使用。

接口介质类型的转换:

// LESS CODE

0
Switch(config)#interface gigabitethernet 0/1
1
Switch(config-if)#medium-type fiber //把接口工作模式改为光口
2
Switch(config-if)#medium-type copper //把接口工作模式改为电口

默认情况下,接口是工作在电口模式。在项目实施中,如果光纤模块指示灯不亮,工作模式是否正确也是故障原因之一。

接口速度/双工配置

命令格式:

// LESS CODE

0
Switch(config)#interface interface-id //进入接口配置模式
1
Switch(config-if)#speed {10 | 100 | 1000 | auto } //设置接口的速率参数,或者设置为auto
2
Switch(config-if)#duplex {auto | full | half} //设置接口的双工模式</p><p>1000只对千兆口有效;默认情况下,接口的速率为auto,双工模式为auto

配置实例:

实例将gigabitethernet 0/1的速率设为1000M,双工模式设为全双工:

// LESS CODE

0
Switch(config)#interface gigabitethernet 0/1
1
Switch(config-if)#speed 1000
2
Switch(config-if)#duplex full

光口不能修改速度和双工配置,只能auto。

VLAN配置

添加VLAN到端口:

在交换机上建立VLAN:

[less]
Switch (config)#vlan 100 //建立VLAN100
Switch (config)#name ruijie //该VLAN名称为ruijie

将交换机接口划入VLAN 100中:

// LESS CODE

0
Switch (config)#interface range f 0/1-48 //range表示选取了系列端口1-48,这个对多个端口进行相同配置时非常有用
1
Switch (config-if-range)#switchport access vlan 100 //将接口划到VLAN100
2
Switch (config-if-range)#no switchport access vlan //将接口划回到默认VLAN 1中,即端口初始配置

交换机端口的工作模式:

// LESS CODE

0
Switch(config)#interface fastEthernet 0/1
1
Switch(config-if)#switchport mode access //该端口工作在access模式下
2
Switch(config-if)#switchport mode trunk //该端口工作在trunk模式下

如果端口下连接的是PC,则该端口一般工作在access模式下,默认配置为access模式。

如果端口是上联口,且交换机有划分多个VLAN,则该端口工作在TRUNK模式下。

NATIVE VLAN配置:

// LESS CODE

0
Switch(config)#interface fastEthernet 0/1
1
Switch(config-if)#switchport mode trunk
2
Switch(config-if)#switchport trunk native vlan 100 //设置该端口NATIVEVLAN100

端口只有工作在TRUNK模式下,才可以配置NATIVE VLAN;

在TRUNK上Native VLAN的数据是无标记的(Untagged),所以即使没有在端口即使没有工作在TRUNK模式下,Native Vlan仍能正常通讯;

默认情况下,锐捷交换机的NATIVE VLAN为1。建议不要更改。

VLAN修剪配置:

// LESS CODE

0
Switch(config)#interface fastEthernet 0/2
1
Switch(config-if)#switchport trunk allowed vlan remove2-9,11-19,21-4094 //设定VLAN要修剪的VLAN
2
Switch(config-if)#no switchport trunk allowed vlan //取消端口下的VLAN修剪

VLAN信息查看:

// LESS CODE

0
Switch#show vlan
1
VLAN Name Status Ports
2
&#8212;- &#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;- &#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;-
3
1 default active Fa0/1 ,Fa0/11,Fa0/12
4
Fa0/13,Fa0/14,Fa0/15
5
Fa0/16,Fa0/17,Fa0/18
6
Fa0/19,Fa0/20,Fa0/21
7
Fa0/22,Fa0/23,Fa0/24
8
100 VLAN0100 active Fa0/1 ,Fa0/2 ,Fa0/3
9
Fa0/4 ,Fa0/5 ,Fa0/6
10
Fa0/7 ,Fa0/8 ,Fa0/9
11
Fa0/10
12
Switch#

三层路由功能( 针对三层交换机)配置
// LESS CODE

0
Switch(config)#ip routing //开启三层交换机的路由功能
1
Switch(config)#interface fastethernet 0/1
2
Switch(config-if)#no switchport //开启端口的三层路由功能(这样就可以为某一端口配置IP)
3
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
4
Switch(config-if)#no shutdown

三层交换机路由协议

// LESS CODE

0
Switch(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1 //配置静态路由
1
注:172.16.1.0 255.255.255.0 为目标网络的网络号及子网掩码,172.16.2.1 为下一跳的地址,也可用接口表示, 如ip route 172.16.1.0 255.255.255.0 serial 1/2(172.16.2.0 所接的端口)
2
Switch(config)#router rip //开启RIP 协议进程
3
Switch(config-router)#network 172.16.1.0 //申明本设备的直连网段信息
4
Switch(config-router)#version 2 //开启RIP V2,可选为version 1(RIPV1) 、version 2(RIPV2)
5
Switch(config-router)#no auto-summary //关闭路由信息的自动汇总功能( 只有
6
RIPV2支持)
7
Switch(config)#router ospf //开启OSPF路由协议进程(针对1762,无需
8
使用进程ID
9
Switch(config)#router ospf 1 //开启OSPF路由协议进程(针对2501,需要加OSPF进程ID
10
Switch(config-router)#network 192.168.1.0 0.0.0.255 area 0 //申明直连网段信息,并分配区域号(area0 为骨干区域)

端口镜像配置
// LESS CODE

0
Switch (config)#monitor session 1 destination interface GigabitEthernet 0/2 //配置G0/2为镜像端口
1
Switch (config)#monitor session 1 source interface GigabitEthernet 0/1 both //配置G0/1为被镜像端口,且出入双向数据均被镜像
2
Switch (config)#no monitor session 1 //去掉镜像1

S21、S35等系列交换机不支持镜像目的端口当作普通用户口使用,如果需要做用户口,请将用户MAC与端口绑定。

锐捷SME交换机镜像支持一对多镜像,不支持多对多镜像。

去除TAG标记:

// LESS CODE

0
Switch (config)#monitor session 1 destination interface GigabitEthernet 0/2 encapsulation replicate // encapsulation replicate表述镜像数据不带TAG标记

目前该功能只有S37、S57、S86、S96交换机支持,其他型号交换机不支持。

锐捷交换机支持两种模式:

镜像目的口输出报文是否带TAG根据源数据流输入的时候是否带TAG来决定。

强制所有的镜像输出报文都不带TAG ,受限于目前芯片的限制,只支持二层转发报文不带Tag,经过三层路由的报文,镜像目的端口输出的报文会带Tag。

端口镜像信息查看:

// LESS CODE

0
S3750#sh monitor session 1
1
Session: 1
2
Source Ports:
3
Rx Only : None
4
Tx Only : None
5
Both : Fa0/1
6
Destination Ports: Fa0/2
7
encapsulation replicate: true

端口聚合配置
// LESS CODE

0
Switch(config)#interface fastEthernet 0/1
1
Switch (config-if)#port-group 1 //把端口f0/1加入到聚合组1
2
Switch (config-if)#no port-group 1 //把端口f0/1从聚合组1中去掉

S2126G/50G交换机最大支持的6个AP,每个AP最多能包含8个端口。6号AP只为模块1和模块2保留,其它端口不能成为该AP的成员,模块1和模块2也只能成为6号AP的成员。

聚合端口需是连续的端口,例如避免把端口1和端口24做聚合。

端口聚合信息查看:

// LESS CODE

0
S3750#show aggregatePort 1 summary //查看聚合端口1的信息
1
AggregatePort MaxPorts SwitchPort Mode Ports
2
&#8212;&#8212;&#8212;&#8212;- &#8212;&#8212;- &#8212;&#8212;&#8212;- &#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;-
3
Ag1 8 Enabled Access Fa0/1 , Fa0/2
4
S3750#

信息显示AP1的成员端口为0/1和0/2。

交换机堆叠配置

设置交换机优先级:

// LESS CODE

0
S3750(config)#device-priorit 5

锐捷交换机的堆叠采用的是菊花链式堆叠,注意堆叠线的连接方法

也可以不设置交换机优先级,设备会自动堆叠成功。堆叠后,只有通过主交换机CONSOLE口对堆叠组进行管理。

查看堆叠信息:

// LESS CODE

0
Student_dormitory_B#show member
1
member MAC address priority alias SWVer HWVer
2
&#8212;&#8212; &#8212;&#8212;&#8212;&#8212;&#8212;- &#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;&#8212;- &#8212;- &#8212;-
3
1 00d0.f8d9.f0ba 10 1.61 3.2
4
2 00d0.f8d9.f2ef 1 1.61 3.2
5
3 00d0.f8ff.d38e 1 1.61 3.3

ACL配置

配置ACL步骤:

建立ACL:

// LESS CODE

0
Switch(config)#Ip access-list exten ruijie //建立ACL访问控制列表名为ruijie,extend表示建立的是扩展访问控制列表
1
Switch(config)#no Ip access-list exten ruijie //删除名为ruijie的ACL

增加一条ACE项后,该ACE是添加到ACL的最后,不支持中间插入,所以需要调整ACE顺序时,必须整个删除ACL后再重新配置。

添加ACL的规则:

// LESS CODE

0
Switch (config-ext-nacl)#deny icmp any 192.168.1.1 255.255.255.0 //禁止PING IP地址为192.168.1.1的设备
1
Switch (config-ext-nacl)#deny tcp any any eq 135 //禁止端口号为135的应用
2
Switch (config-ext-nacl)#deny udp any any eq www //禁止协议为www的应用
3
Switch(config-ext-nacl)#permit ip any any //允许所有行为

将ACL应用到具体的接口上:

// LESS CODE

0
Switch (config)#interface range f 0/1
1
Switch (config-if)#ip access-group ruijie in //把名为ruijie的ACL应用到端口f 0/1
2
Switch (config-if)#no ip access-group ruijie in //从接口去除ACL

1 2
赞(0)
未经允许不得转载:伊阳博客 » 锐捷交换机基本命令
所属分类: 网络硬件

留言 1

  • QQ号
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

表情 关闭

图片
目前评论:1 条  其中:访客  1 条  站长  0 条
  1.  沙发
    窝仔
    窝仔 【农民】(  Firefox 71.0   Windows 10 ) 来自: IP data file not exists or access denied
    发表于10个月前 (01-07)回复

    谢谢,学习了